
NCSS Statistical Software NCSS.com 

1-1 
 © NCSS, LLC. All Rights Reserved. 
 

Chapter 1 

Quick Start 

Before You Install 

Minimum System Requirements 
In order to run NCSS 2025, your computer must meet the following minimum standards. 

Processor: 450 MHz or faster processor 
32-bit (x86) or 64-bit (x64) processor 

RAM: 256 MB (512 MB recommended) 

Operating Systems: Windows 11 or later  
Windows 10  
Windows 8.1  
Windows 8  
Windows 7 
 

Windows Server 2022 or later  
Windows Server 2019 
Windows Server 2016  
Windows Server 2012 R2  
Windows Server 2012 
Windows Server 2008 R2 SP1 

Privileges: Administrative rights required during installation only 

Third Party Software: Microsoft .NET 4.8 (Comes pre-installed with Windows 11 or later, Windows 10 (May 
2019 Update) or later, and Windows Server 2022 or later. Installation required on 
Windows 10 (October 2018 Update (Version 1809)) or earlier and Windows Server 2019 
or earlier. For systems where .NET 4.8 installation is required, a .NET 4.8 download 
helper will start automatically when you run the NCSS setup file.) 

 Microsoft Visual C++ 2015-2022 Redistributable (x86 for 32-bit NCSS or x64 for 64-
bit NCSS) (For systems where Microsoft Visual C++ 2015-2022 Redistributable 
installation is required, a Microsoft Visual C++ 2015-2022 Redistributable installation 
helper will start automatically when you run the NCSS setup file.) 
 

Microsoft Windows Installer 3.1 or higher 
 

Adobe Reader 7 or higher (required for the Help System only) 

Hard Disk Space: 400 MB for NCSS (plus space for Microsoft .NET 4.8 and Microsoft Visual C++ 2015-2022 
Redistributable if not already installed) 

Printer: Any Windows-compatible inkjet or laser printer 
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Installing NCSS 
The installation procedure creates the necessary folders and copies the NCSS program from the installation 
file. The files in the installation file are compressed, so the installation program decompresses these files as 
it copies them to your hard disk. During the installation wizard dialog, you will be able to choose the NCSS 
installation location. 

This section gives instructions for installing NCSS on your computer system. You must use the NCSS setup 
program to install NCSS. The files are compressed, so you cannot simply copy the files to your hard drive. 

Follow these basic steps to install NCSS onto your computer system: 

1. Run the downloaded executable installation file. 

2. Once the setup starts, follow the instructions on the screen. NCSS will be installed to the drive and 
folder you designate during the installation process. 

If Something Goes Wrong During Installation 
The installation procedure is automatic. If something goes wrong during installation, restart the installation 
procedure from the beginning. It may help to restart your computer before retrying the installation. If 
trouble persists, contact our technical support staff. 

Starting NCSS 
NCSS may be started using your keyboard or your mouse using the same techniques that you use to start 
any other Windows application. You can start NCSS by selecting it from your Start menu using standard 
mouse or keyboard operations. 

Entering Your License Key 
The first time you run NCSS, enter your license key in the pop-up window that appears. If you do not enter a 
valid license key, you will be able to navigate among NCSS windows, view the help, and run procedures, but 
you will only be able to obtain sample output. If you purchase a license, you can enter the license key 
anytime by going to the NCSS menu and choosing License. Once you enter a valid license key, the 
evaluation version will become fully functional. You do not need to reinstall NCSS. 

For more information about obtaining a license, visit www.ncss.com. 

Updating NCSS 
We periodically release updates that fix bugs or provide enhancements to your current version of NCSS. 
These updates are provided with all purchased licenses, free of additional charge. You can view the 
problems that each update fixes and download updates from our website at 
www.ncss.com/download/ncss/updates. To determine whether you have the most recent update, click on 
About from the Help menu to find the current version and release date of your installed software. Compare 
this information to that of the updates available at our website.  

http://www.ncss.com/
http://www.ncss.com/
http://www.ncss.com/download/ncss/updates
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The Three Primary NCSS Windows 
NCSS is controlled by three main windows:  

1. Data Window 

2. Procedure Windows 

3. Output Window 

Each window has its own menu bar and tool bar. We will now briefly describe each of the three. 

The NCSS Data Window 
The NCSS Data window contains the data that is currently being analyzed. This window lets you view, 
modify, and save your data. It has the look and feel of a spreadsheet. This is the main NCSS window. Closing 
this window will exit NCSS. 

The Data Window chapter provides a closer look at the Data window. This chapter can be found from the 
general help or by clicking the help button of the Data window. 

The NCSS Procedure Windows 
The NCSS Procedure windows let you set the options for a particular analysis. Whether you are running a 
multiple regression, an ANOVA, or a scatter plot, you will set the options of this procedure in the Procedure 
window. Closing this window will not exit NCSS. 

Clicking the help button in the top right corner of a procedure window will show the help documentation for 
that particular procedure. 

The Procedure Window chapter provides a closer look at the Procedure window. 

The NCSS Output Window 
The NCSS Output window displays the output from the statistical and graphics procedures. It serves as a 
mini-word processor—allowing you to view, edit, save, and print your output. Closing this window will not 
exit NCSS. 

The Output Window chapter takes a closer look at the Output window. This chapter can be found from the 
general help or by clicking the help button of the Output window. 
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Moving from Window to Window 
There are several ways of moving among the windows:  

1. Remove the windows you are not currently using by minimizing them. 

2. Arrange the windows on your screen so that all can be seen. 

3. Use the task bar along the bottom of your screen. 

4. Use the Windows menu. 

5. Use the Navigator. 

6. Use the toolbar (this is usually the quickest and easiest). 

Selecting a Procedure 
There are three primary ways to select a procedure:  

1. Select the procedure from the Data, Analysis, Graphics, or Tools menu. 

2. Click the button of the corresponding procedure from the Favorites, Recent, or Loaded buttons of 
the tool bar. 

3. Select the procedure using the Procedure Navigator (click the Procedures button to open the 
Procedure Navigator). 

Obtaining Help 

Training Videos 
The NCSS product information and training videos give a narrated experience of various aspects of using 
the software and available features. We suggest that you start by watching these videos. You can access all 
of the NCSS videos from our website at www.ncss.com/videos/ncss. They will guide you step-by-step 
through example analyses using the software. 

Help System 
The Help System is started from the Help menu or by clicking on any of the help buttons (blue circle with a 
question mark). In most cases, clicking the help button will open the general help system and then go to the 
chapter corresponding to window in which the help button was pressed. NCSS updates, available for 
download at www.ncss.com, may contain adjustments or improvements of the NCSS Help System. Adobe 
Acrobat or Adobe Reader version 7 or later is required to view the help system. You can download Adobe 
Reader for free by going to www.adobe.com. Adobe Reader can also be installed from the Utilities folder on 
your NCSS installation CD. 

http://www.ncss.com/
http://www.ncss.com/videos/ncss
http://www.ncss.com/
http://www.adobe.com/
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Navigating the Help System 

There are a few key features of our help system that will let you use the help system more efficiently. We 
will now explain each of these features. 

Contents Tab 

Clicking on the Contents tab opens the Contents portion of the viewer. From this tab you can expand the 
table of contents to view nested headings. 

Index Tab 

You can go view the index options by clicking the Index tab. The index allows you to quickly locate keywords 
and/or statistical topics. You can narrow the list of index entries displayed by selecting a specific topic 
category in the uppermost dropdown box. 

Index entries are displayed in the format  

Index Entry CHAPTER NAME         or          CHAPTER NAME     Index Entry. 

You can control which entries are displayed by clicking on the radio buttons at the bottom of the tab 
window. 

Searching a Document 

Right-click on the document and select Find to search for a keyword in the document. 
 

Printing the Documentation 

To print pages from the documentation, click on the Print button at the top of the PDF. This will launch the 
Adobe Reader print dialogue screen. You can choose to print a single page or a range of pages from the 
help file.  

Technical Support 
If you have a question about NCSS, you should first look to the Help system. If you cannot find the answer 
there, look for help on the web at www.ncss.com/support. If you are unable to find the answer to your 
question by these means, contact NCSS technical support for assistance by calling (801) 546-0445 Monday – 
Friday between 8 a.m. and 5 p.m. (MST). You can also contact us by email at support@ncss.com. Our 
technical support staff will help you with your question. 

If you encounter problems or errors while using NCSS, please view our list of recent corrections before 
calling by going to www.ncss.com/download/ncss/updates to find out if you problem or error has been 
corrected by You can download updates anytime by going to the update website. If updating your software 
does not correct the problem, contact us by phone or email. 

To help us answer your questions more accurately, we may need to know about your computer system. 
Please have pertinent information about your computer and operating system available. 
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Creating and Opening a Dataset 

Creating a Dataset 
When the NCSS program is started, it will automatically open an untitled dataset. Here you can enter values 
by typing them directly or copying and pasting from another location. The Fill button at the top may be 
useful for entering columns of data with specific patterns. The column names may be entered in the light 
yellow Column Info portion of the Data window. If it is not showing, click the blue Column Info tab button. 
You can view the column information as columns or rows. To switch between the two, click the Rotate View 
button. 

A dataset is saved by going to the File menu and selecting Save or Save As. 

Opening a Dataset 
To open a dataset you have saved, go to the File menu and select open. You can also open a recently used 
dataset by going to the File menu and selecting Recent, or by selecting from the file list at the bottom of the 
File menu options. To open an example dataset, go to File and select Open Example Data. 

Running a T-Test 
In this example, we will compare the average percent brain weight (of body weight) of small mammals 
(those under 100 kg in weight) to the average percent brain weight of large mammals. 

Opening the Mammals Dataset 
From the NCSS Data window, go to the File menu and select Open Example Data. Select Mammals and press 
OK. 

Setting up the T-Test Procedure 
To open the T-Test procedure, go to the Analysis menu, then Select T-Tests, and then select Two-Sample T-
Test. 

Click the Reset button to reset the Comparing Two Means or Distributions procedure. 

Double-click in the Response Variable(s) box and select Percent. Press OK. 

Double-click in the Group Variable 1 box and select SizeGroup. Press OK. 

Click the green Run button to run the procedure. 
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Viewing T-Test Output 
The results are displayed in the NCSS Output window. 

This T-Test compares the mean percent of the two groups. Often, all you will need is the t-value and 
associated probability level. These are contained in the Equal-Variance T-Test Section. In this case the T-
Value is 3.6496 and the probability level (p-value) is 0.00294. We reject the null hypothesis that means are 
equal. 

A quick glance at the means of the two groups shows that the mean percent for small animals is 1.03 and 
for large animals is 0.13. 

The Two-Sample T-Test chapter of the Help system goes into much more detail on how to perform a T-Test 
analysis. 

Creating a Scatter Plot 
In this example, we plot the sepal length against the petal length for three Iris varieties. 

Opening the Fisher Dataset 
From the NCSS Data window, go to the File menu and select Open Example Data. Select Fisher and press 
OK. 

Setting up the Scatter Plot Procedure 
To open the Scatter Plot procedure, go to the Graphics menu, then select Scatter Plots, and then select 
Scatter Plots. 

Click the Reset button to reset the Scatter Plot procedure. 

Double-click in the Vertical Variable(s) box and select SepalLength. Press OK. 

Double-click in the Horizontal Variable(s) box and select PetalLength. Press OK. 

Double-click in the Grouping Symbol Variable box and select Iris. Press OK. 

Under Format Options, change Value Labels to Value Labels. 

Click the green Run button to run the procedure. 
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Viewing Scatter Plot Output 
The results are displayed in the NCSS Output window. 
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